Payment IVR Degradation

Incident Report for SecurePay

Resolved

Our partner has resolved the issue and payment IVRs are functioning as normal.
Posted Oct 28, 2025 - 11:00 AEDT

Identified

We have identified that some customers' payment IVRs are unable to connect. Callers may hear a message stating that the number is disconnected when attempting to pay over the phone.

We are working with our telephony partner to resolve this issue.
Posted Oct 27, 2025 - 11:18 AEDT
This incident affected: Payment processing - IVR.