SecureFrame Safari Payment Issue
Incident Report for SecurePay
Resolved
We have applied a fix and this issue is now resolved.

Please contact SecurePay on 1300 786 756 if you have any further issues.
Posted Jun 20, 2017 - 15:39 AEST
Investigating
We are investigating an issue with SecureFrame payment processing through Safari.

Safari users are intermittently experiencing a timeout when processing payments. Other browsers are working as normal.

We will provide further updates as they become available.
Posted Jun 05, 2017 - 13:11 AEST
This incident affected: Payment Processing - Web (SecureFrame, DirectPost, SecureBill).