Identified MPDM Transactions Failing
Incident Report for SecurePay
Resolved
We have applied an update - all MPDM payments should now be transacting freely.
Posted Jul 12, 2017 - 14:49 AEST
Identified
We have identified transactions failing with MPDM and are investigating a fix.

For further information please contact us on 1300 786 756
Posted Jul 12, 2017 - 12:41 AEST
This incident affected: Payment Processing - Web (SecureFrame, DirectPost, SecureBill).